Updates

PHP: einde ondersteuning versies 7.0 en ouder


< Terug naar home

PHP is onmisbaar voor de meeste websites, vooral die waarvoor een CMS gebruik wordt, bvb WordPress.

Ondertussen weten de meeste gebruikers hoe belangrijk het is om WordPress en zijn thema’s en plugins up-to-date te houden om hacking te vermijden. Maar hetzelfde geldt voor PHP: ongeveer jaarlijks komt daar een nieuwe ‘major’ versie van uit, waarop dan weer ‘minor’ fixes gelanceerd worden.  Tegelijk met het up-to-dat houden van WordPress, hou je dus best ook PHP up-to-date:

  • Voor het upgraden naar een nieuwe Major versie van PHP ben je zelf verantwoordelijk, behalve wanneer je een “WP-GO” hostingpakket hebt.
  • Voor het upgraden naar een nieuwe Minor versie van PHP zorgt ADIT voor alle klanten, daar dit erg belangrijk is, en de werking van een website niet zal verstoren.

Eind 2018 worden PHP 7.0 en alles wat ouder is, dus ook PHP 5.6 niet meer onderhouden door de ontwikkelaars ervan, The PHP Group, en krijgen ze geen security en bug fixes meer. Daarom zal ADIT er ook geen ondersteuning meer op geven.

Wij raden u zeer nadrukkelijk aan om een upgrade uit te voeren naar PHP 7.2 (klik voor meer info over hoe upgraden).  Op nieuwe hostingpakketten wordt door ADIT sinds ongeveer een half jaar automatisch PHP 7.2 geïnstalleerd. PHP 7.3 wordt binnen een week gelanceerd, maar zal nog niet stabiel zijn, en dus wellicht het eerste kwartaal van 2019 nog niet geschikt voor live websites. Daarna zal ADIT deze versie ook aanbieden en ondersteunen.

Hier een overzicht van de 5 meest recente PHP-versies, met lanceerdatum en einde van de ondersteuning:

VERSIE      RELEASE        END OF LIFE & SUPPORT
  • PHP 5.6      28/08/2014     31/12/2018
  • PHP 7.0      03/12/2015      03/12/2018
  • PHP 7.1       01/12/2016      01/12/2019
  • PHP 7.2     30/11/2017     30/11/2020
  • PHP 7.3       13/12/2018      eind 2021 ?
Contacteer ons